Error endorsing query: rpc error: code = Unknown desc = access denied: channel [mychannel] creator org [Org1MSP] - <nil>


(Varun Raj) #42

For me it looks good though. Let me check again.


(Varun Raj) #43

I think you need to attach the certificate content directly than the path.

"certificateAuthorities": {
    "ca.org1.example.com": {
        "url": "https://ca.org1.example.com:7054",
        "caName": "ca.org1.example.com",
        "httpOptions": {
            "verify": false
        },
        "tlsCACerts": {
            "pem": "-----BEGIN CERTIFICATE----- <etc> "
        }
    }
}

(Saeedi) #44

Same error is reproduced…

lubuntu@lpeer1:~$ composer identity request -c PeerAdmin@byfn-network-org1 -u admin -s adminpw -d alice
Error: failed to request identity. Error trying to enroll user and return certificates. Error: Calling enrollment endpoint failed with error [Error: write EPROTO 139870414554944:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:…/deps/openssl/openssl/ssl/s23_clnt.c:827:
]
Command failed


(Saeedi) #45

Had to rename caName and enabled tls mode in .yaml file. Now it works. :blush::blush::blush:


(Saeedi) #46

Everything is working now as i have been able to complete this tutorial Thanks a lot :slight_smile:
There is only one problem, that it is taking way too long to execute commands like network ping identity request etc.


(Varun Raj) #47

Oh that’s nice :slight_smile: the speed depends on various factors importantly since it’s distributed network there will be more latency.


(Saeedi) #48

Thanks :slight_smile: Yeah maybe i am using vms and that is causing this.


(Varun Raj) #49

Yep, that might be the issue :slight_smile:


(Saeedi) #50

Hey @varun, is it possible to extend network using docker swarm specifically the boilerplate provided by you ?
I have been trying to accomplish this. With your guidance i was able to successfully deploy network using 2 virtual machines. I created 3rd virtual machine for this scenario and rather than relaunching all scripts, i only executed this command

./scripts/network/deploy_services_org3.sh

in the CLI and it works fine. But this is the error it reproduces
lubuntu@flpeer1:~$ docker service ps hlf_orderer_orderer_org3

ID NAME IMAGE NODE DESIRED STATE CURRENT STATE ERROR PORTS
ryq1fvzid27s hlf_orderer_orderer_org3.1 hyperledger/fabric-orderer:1.2.1 Running Pending 8 minutes ago “no suitable node (scheduling …”

Although i have configured 3rd vm exactly like i did previous ones but this issue is recurring. All hosts are active also.

ID HOSTNAME STATUS AVAILABILITY MANAGER STATUS ENGINE VERSION
lzmzyn9nb8nodh00hlk98p4tg * flpeer1 Ready Active Leader 18.09.0
az2xv28qo216cjhfsak0qninq flpeer2 Ready Active 18.09.0
ryymgwodt9qkzdvibziol3hch flpeer3 Ready Active 18.09.0


(Varun Raj) #51

Hello @Saeedi Do you want to extended it without restarting the network? or want to create new config for fresh network.


(Saeedi) #52

I want to extend it without restarting network


(Varun Raj) #53

In that case you need to follow the IBM’s method.


(Saeedi) #54

Got It. Thank you. Previously mentioned error was solved by renaming hostname. There was a mistake in renaming hosts.


(Varun Raj) #55

Oh great. But we’ve did one implementation with docker swarm that can be extended to add new organization. Soon I’ll add an article about it


(Saeedi) #56

Thanks. Will be waiting for another amazing article. :smile:


(Varun Yadavalli) #57

Hi,
I’m facing same issue, when I instantiated the chaincode in one of the org peer.
I did checked every peer is up and verified that I added peers to channel.

2018-11-21 18:30:21.805 UTC [msp/identity] Sign -> DEBU 04d Sign: digest: B93B1ED9E8485724D35B9E78ED521BC6AAD3EBA9AF0759F291BB928A4C453F8D 
Error: error endorsing chaincode: rpc error: code = Unknown desc = access denied: channel [mychannnel] creator org [BMWMSP]

(Varun Raj) #58

Can you check if you’re using the right certificates for instantiating the chaincode?


(Varun Yadavalli) #59

Nevermind, this is problem with my command, thank you.


(Varun Raj) #60

Glad to hear that. Btw what do you think about the article? Finding it useful?


(Varun Yadavalli) #61

Yes it is, and i’m walking thorough your articles regarding HLF, simple to understand and useful.
Thanks, great work.